Jump to content


Photo
- - - - -

My XD ESP


  • Please log in to reply
51 replies to this topic

#41 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 02 May 2010 - 05:00 PM

Pulled the convertor apart, all the diaphragms are good and its very clean inside so no probs with that.

#42 xw351

xw351
  • Member
  • PipPipPip
  • 288 posts
  • Reputation: 3
  • Car:XW Falcon

Posted 03 May 2010 - 12:02 PM

Ok can you verify that the smaller of the venturi's is on the primary and can you check that the progression port hoses have vacuum on them when running, it may be that the line isn't supplying LPG in the range from off idle to 1500rpm which is creating a flat lean spot.

Yea the VFF30 has limitations, I used to have it close on my when I got to WOT sometimes which was a pain in the butt.
11.3 @120mph on BBQ/N2O that was then, now we're going tarmac racing.

#43 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 03 May 2010 - 06:51 PM

Will have a look which side has which venturi. I dont think the problem is that the progression port is not supplying gas, i think its the idle circuit is not getting gas as the vacuum isn't strong enough below 1500 rpm. It definitely stalls because it is running out of gas as i need to use the primer to get it to start again. My opinion is the air speed and vacuum signal of my engine is not strong enough at idle to pull the gas into the idle circuit but this is my only experience with gra so im not really sure about it. Not sure what to do, i pulled the whole system off and went back to the 425 for now as im sick of not driving the car.

#44 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 03 May 2010 - 07:38 PM

The small venturi is definitely on the primary side.

#45 xw351

xw351
  • Member
  • PipPipPip
  • 288 posts
  • Reputation: 3
  • Car:XW Falcon

Posted 04 May 2010 - 01:55 PM

Oh that's a bummer!! I was going to suggest taking it to a performance LPG place and getting them to check the mixtures and or anything that might be causing an issue.
11.3 @120mph on BBQ/N2O that was then, now we're going tarmac racing.

#46 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 04 May 2010 - 05:54 PM

I am going to see if i can borrow another throttle body and try it on the primary side. Did you cut anything off the inside of the throttle body to fit the venturis? I may have to send it back to gas research and get the standard diffuser fitted to the primary throttle body. Also are the springs in the primary convertor standard?

Edited by ESP357, 04 May 2010 - 06:01 PM.


#47 xw351

xw351
  • Member
  • PipPipPip
  • 288 posts
  • Reputation: 3
  • Car:XW Falcon

Posted 05 May 2010 - 04:43 PM

The only thing that get removed is the internal venturi, If you want to you can buy an S400 or S440 insert from them and fit it yourself, I did have issues in the very beginning with a very similar problem but when I changed to alloy heads with 11.5 to 1 comp it really sorted out a lot of issues.

Can you still get someone to have a look at the mixtures?

I am sure that the springs are std GRA items except that the secondary has some shim washer under the springs.

Did you verify that there are no air leaks anywhere?
11.3 @120mph on BBQ/N2O that was then, now we're going tarmac racing.

#48 ltd351t

ltd351t
  • Member
  • PipPipPip
  • 3877 posts
  • Reputation: 1610
  • Location:Canberra
  • State:ACT
  • Car:Scooter

Posted 05 May 2010 - 06:54 PM

What seems strange to me is that it revs better with both throttle bodies working, as opposed to just the primary. I'd try it with just the primary, if it still has problems its a gas supply or leakage issue, IE perforated converter diaphragm loosing vacuum, etc, or similar.

You could also try just the secondary throttle, if that works better you have an issue with the primaries converter.

Its really hard to make judgement without AFR data.
www.TURBO351.com

www.danspec.net

FD LTD, 747rwhp on LPG.

#49 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 05 May 2010 - 07:00 PM

There are no air leaks, i checked all that. As for the mixtures, im 99% sure its not that as i can get it very rich or very lean (so lean the pipes glow) and i can also get the throttle body to whistle which is usually the best setting for throttle response. I think the problem is the lack at of air speed and vacuum at below 1500 rpm not giving enough signal for the gas to be pulled from the convertor. I think its the same problem as when a standard impco or b2 convertor is used with a gra mixer. I believe it wasn't an issue on your engine because of your higher compression ratio and better heads. Glad to hear no lugs or anything were cut off to fit the insert. I didn't know that they would sell the insert to me, i thought i had to send it back to them. I think that is what i'll do but i will keep the billet venturi and re install it when i get a set of chi heads and up the comp. Will let you know how i go.

#50 ESP357

ESP357
  • Member
  • PipPipPip
  • 394 posts
  • Reputation: 60
  • Car:xd esp

Posted 05 May 2010 - 07:10 PM

What seems strange to me is that it revs better with both throttle bodies working, as opposed to just the primary. I'd try it with just the primary, if it still has problems its a gas supply or leakage issue, IE perforated converter diaphragm loosing vacuum, etc, or similar.

You could also try just the secondary throttle, if that works better you have an issue with the primaries converter.

Its really hard to make judgement without AFR data.

I tried to get it to idle on the secondary mixer and it wont idle on either of them. I just remembered a while ago i tried holding the primer button down and it will idle in gear with the primer on thats why i think its a starvation problem. I've had the convertor apart and all the diaphragms look ok. Even though i can hear a whisper of gas coming through after the engine is stopped, the convertor holds gas as hitting the primer on the convertor with the engine stopped releases gas. I really just learning about the gra stuff so i appreciate yours and matts help sorting it out.

#51 xw351

xw351
  • Member
  • PipPipPip
  • 288 posts
  • Reputation: 3
  • Car:XW Falcon

Posted 06 May 2010 - 11:42 AM

Thanks for chipping in Charles, much appreciated.
That whistling noise was the best indicator for me when the engine was idling really nicely. I don't think that I ever tried to get it to just idle on one throttle.
11.3 @120mph on BBQ/N2O that was then, now we're going tarmac racing.

#52 xd_esp

xd_esp
  • Member
  • PipPipPip
  • 32 posts
  • Reputation: 0
  • Car:XD ESP

Posted 22 January 2012 - 12:19 AM

nearly the same as my sweet ride .great car




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users